If a plugin is “Untested with your version of WordPress” should you use it?

Many WordPress users don’t know whether they should use a plugin with the warning saying it hasn’t been tested with the current version of WordPress. This is an important issue, as it could cause issues on your website, if it doesn’t work with your version of WordPress. Here is what you should know about using untested WordPress plugins.
WordPressPluginWarning

Where does the Not Tested Information Come From?

WordPress provides the largest repository of free and open source plugins within the WordPress Plugin Repository. When an author of a plugin submits it to the repository, they have to submit a “readme” file. This file is used by the plugin directory to create the page for the plugin. It will also include a “tested up to” tag, which will display in the information for the plugin testing.
When WordPress comes out with a new version, it’s up to the plugin author to update the readme files and test the plugins. However, not all authors do this. When a plugin author doesn’t test their plugin with a new version, the warning message will appear.

Should You Use Untested WordPress Plugins?

In many cases, the plugins with warnings will work just fine and won’t cause any issues. You should feel free to use these plugins, even though the author hasn’t tested them with the latest version of WordPress.
It’s always worth trying even if the plugin happens to not work with the newest version. If this happens, you will find out very quickly and you can simply delete the plugin from your website.
However, there is an exception to this rule. If the plugin hasn’t been updated in more than two years, it’s probably abandoned by the author. This is a plugin you should not install. Without updates, the plugin can cause issues and you will be installing it at your own risk. It will slow down the wordpress site process due to increase in allotted resource usage.
untested wp plugin issue
If the plugin doesn’t work with your version of WordPress because you are using an older version, it might be time to update. WordPress often releases new versions for security reasons and the updates are quite important. Make sure you are updated to the most current version of WordPress, and then try using the plugin again.

You can Help Other WordPress Users

When you install a WordPress plugin that hasn’t been tested with your version of WordPress, you can help other users out. If it works just fine, go back to the plugin page at WordPress.org, log in
compatibility
Just choose the version of WordPress you are using, the plugin version and click the “Works” button. Then, when other WordPress users land on the page and they want to know if the plugin will work, they can see your answer in the Compatibility Section.
Answer for compatibility

What Should You do if the Plugin Doesn’t Work?

If the plugin doesn’t work, you don’t need to leave a harsh comment for the author. Remember, these are free plugins with no warranty or guarantee. The author has been nice enough to provide the plugin free of charge, so there’s no reason to be harsh if it doesn’t work.
Instead, simply describe the issue you are having with the plugin in the support thread. The author or somebody else in the community may respond to help with the issue. If nobody responds after a few weeks, try reaching out to the author of the plugin. If you still don’t get a response, you can vote on the plugin page for it being broken under the compatibility section.
After you mark the plugin as broken, you can search for another plugin that does the same thing or something similar. There are often multiple plugins capable of doing the same thing. It may not be very difficult to find another plugin that will do the same thing and will work with your version of WordPress.
Just because a WordPress plugin has a warning due to lack of testing, doesn’t mean it won’t work for you. It’s still possible to use untested WordPress plugins and often they will work. However, if it has been two years or longer since the plugin has been updated, be careful using it
Theme images by LonelySnailDesign. Powered by Blogger.